PySceneDetect v0.5 Manual

This manual refers to both the PySceneDetect command-line interface (the scenedetect command) and the PySceneDetect Python API (the scenedetect module).

Information regarding installing/downloading PySceneDetect or obtaining the latest release can be found at scenedetect.com. Both Python 2.7 and 3.x are supported, however it is suggested to use or migrate to Python 3.x whenever possible, as it provides better overall performance.

PySceneDetect requires ffmpeg or mkvmerge for video splitting support.

Note

If you see any errors in this manual, or have any recommendations, feel free to raise an issue on the PySceneDetect issue tracker.

The latest source code for PySceneDetect can be found on Github at github.com/Breakthrough/PySceneDetect.